Nýjast Cisco höfuðverkurinn.

Netbúnaður, uppsetningar, WAN, LAN, heimanet og internet.
Skjámynd

Höfundur
sprelligosi
Fiktari
Póstar: 91
Skráði sig: Mið 23. Okt 2002 03:46
Reputation: 0
Staða: Ótengdur

Nýjast Cisco höfuðverkurinn.

Pósturaf sprelligosi » Fim 09. Júl 2009 01:36

Jæja, þannig er mál með vexti að ég er að verða búinn að setja upp allt netkerfið hérna heima. Það er bara einn hængur á ég er með Cisco 877 router og er búinn að græja allt. Nema hvað ég er búinn að vera í bölvöðu brasi með að rigga adsl sjónvarpinu.
Ég fór nú samt eitthvað á stjá á Google og fann eitthvað mac-spjallborð þar sem að einhver náungi var í svipuðu basli.

Hérna fyrir neðan er configgið mitt og svo configgið hans. Hann er með eitthvað VPN (vrf) sem ég er ekki alveg að skilja útaf hverju og fatta ekki alveg hvernig það er að virka.

Það sem að ég vildi vita hvort að það væri ekki bara nóg að vera með margar PVC á einu interface. td PVC 7/48 7/50 7/51interface fastethernet3 eins og hann er með. Sleppa þá VPN (vrf).


Með von um minkandi neyslu sterkra verkjataflna.
Kveðja Heiðar

----------------------------------------------------------------------------

Config sem ég fann á: http://maclantic.is/spjall/viewtopic.ph ... d461d8ec31

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool sdm-pool
import all
vrf Simnet
network 192.168.1.0 255.255.255.0
dns-server 194.105.224.1
default-router 192.168.1.1
!
!
ip vrf Simnet
rd 1:1
!
ip multicast-routing
no ip ips deny-action ips-interface
ip igmp snooping vlan 3 immediate-leave
no ip igmp snooping
no ip igmp ssm-map query dns
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
pvc 8/48
pppoe-client dial-pool-number 1
!
!
interface ATM0.10 multipoint
description TV Skjarinn
pvc 7/48
description Portal
!
pvc 7/50
description IGMP
!
pvc 7/51
description Video
!
bridge-group 10
!
interface FastEthernet0
switchport access vlan 2
!
interface FastEthernet1
switchport access vlan 2
!
interface FastEthernet2
!
interface FastEthernet3
description TV Skjarinn
switchport access vlan 3
duplex half
spanning-tree portfast
hold-queue 1024 in
hold-queue 1024 out
!
interface Vlan1
no ip address
!
interface Vlan2
ip vrf forwarding Simnet
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Vlan3
description TV vlan
no ip address
ip pim sparse-mode
bridge-group 10
!
interface Dialer0
ip vrf forwarding Simnet
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp chap refuse
ppp pap sent-username [NOTANDI]@simnet.is password [LYKILORÐ]
!
ip classless
ip route vrf Simnet 0.0.0.0 0.0.0.0 Dialer0
!
!
ip nat inside source list ADSL_Simnet interface Dialer0 vrf Simnet overload
!
ip access-list standard ADSL_Simnet
permit 192.168.1.0 0.0.0.255
!
access-list 10 permit 239.10.10.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
bridge 10 protocol ieee
!
scheduler max-task-time 5000
end

-----------------------------------------------------------------------------
Configgið mitt:

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXXXX
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
!

dot11 syslog
dot11 vlan-name WIRELESS vlan 1
!
dot11 ssid Cisco
vlan 1
authentication open
guest-mode
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.10
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.100
!
ip dhcp pool DHCP_LAUGIN
network 192.168.1.0 255.255.255.0
dns-server 212.30.200.199 212.30.200.200
default-router 192.168.1.254
domain-name mydomain.com
!
!
ip name-server 212.30.200.199
ip name-server 212.30.200.200
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
username XXXX privilege 15 password 0 XXXXXX
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/48
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 key 1 size 40bit 0 XXXXXXXXXX transmit-key //já ég veit að wep er hrikalegt :)
encryption vlan 1 mode wep mandatory
!
ssid Cisco
!
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
ip virtual-reassembly
ip tcp adjust-mss 1412
bridge-group 1
hold-queue 100 out
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username XXXXXXXXXXX password 0 XXXXXXXX
!
interface BVI1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip default-gateway 192.168.1.254
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list NAT_INNI interface Dialer0 overload
!
ip access-list standard NAT_INNI
permit 192.168.1.0 0.0.0.255
remark IP ADDRESSUR PRIVATE
!
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner motd ^CHVAD ER I GANGI^C
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end



Skjámynd

depill
Stjórnandi
Póstar: 1396
Skráði sig: Mán 04. Júl 2005 17:09
Reputation: 141
Staðsetning: Reykjavík, Iceland
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf depill » Fim 09. Júl 2009 10:27

Ættir ekki að þurfa að setja þetta í vrf, vrf gerir bara sér "routing" instance, en þú ert bara að fara brúa interfaceið yfir þannig að þú ekki að þurfa þess þig vantar.


ip multicast-routing
no ip ips deny-action ips-interface
ip igmp snooping vlan 3 immediate-leave
no ip igmp snooping
no ip igmp ssm-map query dns

interface ATM0.10 multipoint
description TV Skjarinn
pvc 7/48
description Portal
!
pvc 7/50
description IGMP
!
pvc 7/51
description Video
!
bridge-group 10

interface FastEthernet3
description TV Skjarinn
switchport access vlan 3
duplex half
spanning-tree portfast
hold-queue 1024 in
hold-queue 1024 out

interface Vlan3
description TV vlan
no ip address
ip pim sparse-mode
bridge-group 10


bridge 10 protocol ieee

Sko ég hef séð þetta config og hann notar access-list 10 til að permita multicast. Ég er ekki að sjá ða það sé að fara gera eithvað fyrir þetta og ég myndi persónulega bara sleppa því og henda inn ofangreindu configi, það ætti að virka. Það verður þá Fa3 ( síðasta portið á routernum ) sem verður fyrir ADSL sjónvarp Símans




JReykdal
Gúrú
Póstar: 505
Skráði sig: Lau 04. Des 2004 18:59
Reputation: 43
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf JReykdal » Fös 10. Júl 2009 15:02

Svo þarf að vera með advanced-ip firmware en ekki advanced-security sem er algengast á 877.


Vinsamlegast athugið: Skoðanir mínar sem birtast hér eru mínar og mínar einar en ekki
vinnuveitenda minna,vina og vandamanna, gæludýra og húsgagna nema annað sé tekið fram.

Skjámynd

Höfundur
sprelligosi
Fiktari
Póstar: 91
Skráði sig: Mið 23. Okt 2002 03:46
Reputation: 0
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf sprelligosi » Mið 15. Júl 2009 21:19

Jæja þessi höfuðverkur ætlar eitthvað að ílengjast. Ég er nú ekki búinn að geta verið að vinna mikið í þessu þar sem að ég er sjómaður.
Ég setti mig aðeins í samband við þennan Reykdal á maclantic.is spjallinu. Hann vildi meina að ég þyrfti að vera með vrf til að fá það til að virka.
Ég er ekki alveg að kaupa það.

Hérna er configgið sem er í gangi núna. Sjáiði eitthverjar villur?

Ég get svo líka "paste-að" einhverjum show commands ef að því er að skipta.

Kveðja Heiðar




------------------------------
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rooney
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 $1$DGqS$qh1jyp11SjWe0wA0lOYy3/
!
aaa new-model
aaa local authentication attempts max-fail 3
!
!
!
!
aaa session-id common
!
quit
dot11 syslog
dot11 vlan-name WIRELESS vlan 1
!
dot11 ssid Cisco
vlan 1
authentication open
guest-mode

!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.10
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.100
!
ip dhcp pool DHCP_LAUGIN
network 192.168.1.0 255.255.255.0
dns-server 212.30.200.199 212.30.200.200
default-router 192.168.1.254
domain-name mydomain.com

!
!
ip name-server 212.30.200.199
ip name-server 212.30.200.200
ip multicast-routing
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip igmp snooping vlan 3 immediate-leave
no ip igmp snooping
no ip igmp ssm-map query dns
!
multilink bundle-name authenticated
!
!
username XXXX privilege 15 password 0 XXXXX
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/48
pppoe-client dial-pool-number 1
!
!
interface ATM0.10 multipoint
description TV_SKJARINN
pvc 7/48
description PORTAL
!
pvc 7/50
description IGMP
!
pvc 7/51
description VIDEO
!
bridge-group 10
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
description TV SKJARINN
switchport access vlan 3
duplex half
speed 100
spanning-tree portfast
hold-queue 1024 in
hold-queue 1024 out
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 key 1 size 40bit 0 XXXXXXX transmit-key
encryption vlan 1 mode wep mandatory
!
ssid Cisco
!
speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding

!
interface Vlan1
no ip address
ip virtual-reassembly
ip tcp adjust-mss 1412
bridge-group 1
hold-queue 100 out
!
interface Vlan3
description TV VLAN
no ip address
ip pim sparse-mode
bridge-group 10
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username XXXXX password 0 XXXXX
!
interface BVI1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip default-gateway 192.168.1.254
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list NAT_INNI interface Dialer0 overload
!
ip access-list standard NAT_INNI
permit 192.168.1.0 0.0.0.255
remark IP ADDRESSUR PRIVATE
!
dialer-list 1 protocol ip permit
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 10 protocol ieee
banner motd ^CHVAD ER I GANGI^C
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler max-task-time 5000
end



Skjámynd

Höfundur
sprelligosi
Fiktari
Póstar: 91
Skráði sig: Mið 23. Okt 2002 03:46
Reputation: 0
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf sprelligosi » Mán 20. Júl 2009 10:14

Any thoughts?
Einhver? :)




Kristján Gerhard
spjallið.is
Póstar: 465
Skráði sig: Mið 17. Maí 2006 20:27
Reputation: 18
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf Kristján Gerhard » Mán 20. Júl 2009 12:28

þetta er configgið eins og það keyrir hjá mér, TVoDSL virkar og ekki er notast við VRF þar sem að öllu sem viðkemur
TVoDSL er brúað á eitt eth.port á routernum.

Kóði: Velja allt

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$.eM4$ExGlW8wL4KpbRYysMOGmA/
!
no aaa new-model
!
resource policy
!
clock timezone PCTime 0
ip cef   
!         
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.254
ip dhcp excluded-address 192.168.1.200 192.168.1.210
!
ip dhcp pool VLAN1_DHCP
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254
   dns-server 212.30.200.200 194.105.224.1
!
!
ip telnet source-interface Vlan2
no ip domain lookup
ip domain name simnet.is
ip name-server 212.30.200.200
ip name-server 212.30.200.199
ip multicast-routing
no ip igmp snooping vlan 3
ip igmp ssm-map enable
no ip igmp ssm-map query dns
!
ftp-server enable
!
crypto pki trustpoint TP-self-signed-1959113867
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1959113867
 revocation-check none
 rsakeypair TP-self-signed-1959113867
!
!
username XXXXXXXXXXXXXXXXX
!
!
!
bridge irb
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!         
interface ATM0.1 point-to-point
 description $ES_WAN$
 ip access-group 101 in
 no snmp trap link-status
 pvc 8/48
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
 !
!
interface ATM0.10 multipoint
 description TVoDSL Siminn
 no snmp trap link-status
 pvc 7/48
  description Portal Channel
 !
 pvc 7/50
  description IGMP Channel
 !
 pvc 7/51
  description Video Channel
 !
 bridge-group 10
!
interface FastEthernet0
 description Local Area Network
 switchport access vlan 2
!
interface FastEthernet1
 description Local Area Network
 switchport access vlan 2
!
interface FastEthernet2
 description Local Area Network
 switchport access vlan 2
!
interface FastEthernet3
 description TV
 switchport access vlan 3
 spanning-tree portfast
 hold-queue 1024 in
 hold-queue 1024 out
!
interface Dot11Radio0
 no ip address
 !       
 encryption key 1 size 40bit 7 9E4AFC5573E5 transmit-key
 encryption mode wep mandatory
 !
 ssid Alpha_Quadrant
    authentication open
    guest-mode
    infrastructure-ssid optional
 !
 world-mode dot11d country IS both
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Vlan2
 description $ES_LAN$
 no ip address
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface Vlan3
 description TVoDSL Vlan
 no ip address
 ip pim sparse-mode
 bridge-group 10
!
interface Dialer0
 ip address negotiated
 ip access-group 101 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp chap refuse
 ppp pap sent-username xxx.is password 7 xxx
!
interface Dialer1
 no ip address
 no cdp enable
!
interface BVI1
 description LAN
 ip address 192.168.1.254 255.255.255.0
 ip access-group 100 in
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
!
ip route 0.0.0.0 0.0.0.0 Dialer0 name DEFAULT
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat pool quicksilver 192.168.1.100 192.168.1.100 netmask 255.255.255.0 type rotary
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.100 80 interface Dialer0 80
ip nat inside source static udp 192.168.1.3 51336 interface Dialer0 51336
ip nat inside source static tcp 192.168.1.3 51336 interface Dialer0 51336
ip nat inside destination list 102 pool quicksilver
ip nat inside destination list 103 pool quicksilver
!
access-list 1 remark NAT
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 10 permit 239.10.10.0 0.0.0.255
access-list 23 remark TELNET
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 50 permit 192.168.1.0 0.0.0.255
access-list 100 remark LAN
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 102 permit tcp any any range 40000 50000
access-list 102 permit udp any any range 40000 50000
access-list 103 permit tcp any any range 1700 1702
access-list 103 permit udp any any range 1700 1702
dialer-list 1 protocol ip permit
snmp-server community public RO 50
no cdp run
!
!
!
!
control-plane
!         
bridge 1 protocol ieee
bridge 1 route ip
bridge 10 protocol ieee
banner login ^CCCAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 logging synchronous
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
ntp clock-period 17175188
ntp server 157.157.255.11
end



Skjámynd

natti
Gúrú
Póstar: 585
Skráði sig: Fös 10. Jan 2003 09:59
Reputation: 11
Staðsetning: 107
Hafðu samband:
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf natti » Mán 20. Júl 2009 13:33

Þú þarft ekki að nota vrf.

Ég er ekki með kveikt á routernum heima til að bera saman við núna, en...

Þú getur notað "sh bridge verbose" til að hjálpa þér við að troubleshoota.
Þá geturu fylgst með RX & TX undir bridge-group 10...

Líka ein spurning: Ertu búinn að "búa" til vlan 3, eða gerðiru bara "interface vlan 3"?

Ef þú gerir "sh vlan-switch" þá áttu að sjá þau vlan sem eru til á boxinu. Vlan3 á að vera í þeim lista...


Mkay.

Skjámynd

Höfundur
sprelligosi
Fiktari
Póstar: 91
Skráði sig: Mið 23. Okt 2002 03:46
Reputation: 0
Staða: Ótengdur

Re: Nýjast Cisco höfuðverkurinn.

Pósturaf sprelligosi » Þri 21. Júl 2009 00:53

Takk fyrir hjálpina ég kíki á þetta þegar að ég mæti í land.