Ég fæ packetloss á allt nema Google!

Netbúnaður, uppsetningar, WAN, LAN, heimanet og internet.
Skjámynd

Höfundur
izelord
Nörd
Póstar: 147
Skráði sig: Þri 24. Sep 2002 17:29
Reputation: 12
Staðsetning: Hafnarfjörður
Hafðu samband:
Staða: Ótengdur

Ég fæ packetloss á allt nema Google!

Pósturaf izelord » Mán 14. Sep 2020 23:19

Sælir.

Það var erfitt að velja nafn á þráðinn.

tldr; Ég fæ packetloss á allt nema Google!

1. Setuppið er ljósleiðari hjá Símanum. Unifi USG með slökkt á filterum og deep packet inspection.

2. Ein vél keyrir stanslaust ping á mismunandi destination ip til að kanna gæði tengingarinnar. Packetlossið er svona eftir 48 klst:


    Innanhúss á USG: 0%
    Fyrsta hop eftir USG (157.157.73.1): 8.9%
    ns1.hringdu.is: 9.3%
    ns3.internet.is: 8.7%
    simnet.is: 9.0%
    static.hugi.is: 9.0%
    vaktin.is: 9.4%
    yahoo.com: 8.9%
    google.com: 0%
    Google DNS - 8.8.8.8: 0%

Eins og sést þá er ekkert packetloss að routernum og eins og ég sé þetta ætti að vera ~9% packetloss á ALLT ef fyrsta hop er með ~9%. En einhverra hluta vegna fæ ég ekkert packetloss á þessar tvær Google þjónustur.

Varðandi mögulega undarlega uppsetningu á vélinni þá skal það tekið fram að á allt annarri vél með allt annað stýrikerfi er ég einnig að fá packetloss. Meðan þráðurinn var skrifaður var ég með ping á simnet.is og 8.8.8.8 og niðurstaðan samsvaraði áðurnefndu algerlega, 10% vs 0 %.

Traceroute á þessi destination sýna að fyrsta hop er alltaf það sama. Þar af leiðandi, eins og hefur komið fram, ætti ping á google.com að vera með packetloss, að ég hefði haldið.

Til að gera þetta furðulegra þá er mynstur í þessu, þe. að í einhverjum tilvikum þá eru packetloss spikes á sama fresti. Hér er grafið yfir vaktin.is:

Mynd

En svo lítur simnet.is svona út:

Mynd

ns3.internet.is:

Mynd


Ég er að sjá mynstur í hverju og einu en innbyrðis virðist það ekki vera sambærilegt.

Mér datt fyrst í hug að USG væri að droppa ICMP echo replies en get ekki ímyndað mér afhverju þessar tvær Google þjónustur ættu að vera öðruvísi en allir hinir.

Hvað segja menn um þetta mystery? Hvað myndu menn skoða næst?



Skjámynd

Höfundur
izelord
Nörd
Póstar: 147
Skráði sig: Þri 24. Sep 2002 17:29
Reputation: 12
Staðsetning: Hafnarfjörður
Hafðu samband:
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf izelord » Lau 26. Sep 2020 15:54

Update:
Búið að mæla línuna án vandræða
Búið að skipta um netsnúru milli ljósleiðarabox og USG
Búið að uppfæra firmware á öllu, USG meðtöldu.

Fann að juno.isnic.is skilar einnig 0% packetlossi, spurning hvað það á sameiginlegt við Google. Er síðan að fikra mig áfram með iperf til að reyna að átta mig á því hvort þetta sé bara drop á ICMP.

Síðan er að lokum external test frá vél utan netsins. Hún er annarsvegar með 4G hjá Símanum og hinsvegar á ljósleiðara Origo. Blátt vs rautt.

Mynd

Average er 9% á mína IP á meðan það er 0% á aðra til samanburðar. Aftur er augljóst mynstur.



Skjámynd

Hjaltiatla
Vaktari
Póstar: 2388
Skráði sig: Mið 07. Okt 2009 20:54
Reputation: 318
Staðsetning: ::1
Staða: Tengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf Hjaltiatla » Lau 26. Sep 2020 16:11

Ertu að pinga beint ip tölur eða dns addressur ?
Edit: Bara svona til að reyna að útiloka DNS-inn sem er stilltur á router.
Síðast breytt af Hjaltiatla á Lau 26. Sep 2020 16:17, breytt samtals 1 sinni.


Just do IT
  √

Skjámynd

Höfundur
izelord
Nörd
Póstar: 147
Skráði sig: Þri 24. Sep 2002 17:29
Reputation: 12
Staðsetning: Hafnarfjörður
Hafðu samband:
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf izelord » Lau 26. Sep 2020 16:20

Hjaltiatla skrifaði:Ertu að pinga beint ip tölur eða dns addressur ?


Góð spurning, bæði.

T.d. er google.com og gmail.com DNS addressur á meðan 8.8.8.8 og juno.isnic.is eru beinar ip tölur. Báðar aðferðir gefa 0% packetloss. Síðan er ég með beina iptölu á simnet.is en dns færsluna hjá ns1.hringdu.is og báðar aðferðir gefa ~9% packetloss.

Það er því ekki að sjá að það sé munur á aðferðum.



Skjámynd

Hjaltiatla
Vaktari
Póstar: 2388
Skráði sig: Mið 07. Okt 2009 20:54
Reputation: 318
Staðsetning: ::1
Staða: Tengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf Hjaltiatla » Lau 26. Sep 2020 16:24

izelord skrifaði:
Hjaltiatla skrifaði:Ertu að pinga beint ip tölur eða dns addressur ?


Góð spurning, bæði.

T.d. er google.com og gmail.com DNS addressur á meðan 8.8.8.8 og juno.isnic.is eru beinar ip tölur. Báðar aðferðir gefa 0% packetloss. Síðan er ég með beina iptölu á simnet.is en dns færsluna hjá ns1.hringdu.is og báðar aðferðir gefa ~9% packetloss.

Það er því ekki að sjá að það sé munur á aðferðum.

Ef ég væri kominn þetta langt í villugreiningarferlinu myndi ég einfaldlega redda mér öðrum router (til að útiloka main router).
Edit: einfaldlega til að átta mig á því hvar ég á að eyða tímanum í að villugreina nánar
Síðast breytt af Hjaltiatla á Lau 26. Sep 2020 16:26, breytt samtals 1 sinni.


Just do IT
  √

Skjámynd

Höfundur
izelord
Nörd
Póstar: 147
Skráði sig: Þri 24. Sep 2002 17:29
Reputation: 12
Staðsetning: Hafnarfjörður
Hafðu samband:
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf izelord » Lau 26. Sep 2020 16:32

Hjaltiatla skrifaði:
izelord skrifaði:
Hjaltiatla skrifaði:Ertu að pinga beint ip tölur eða dns addressur ?


Góð spurning, bæði.

T.d. er google.com og gmail.com DNS addressur á meðan 8.8.8.8 og juno.isnic.is eru beinar ip tölur. Báðar aðferðir gefa 0% packetloss. Síðan er ég með beina iptölu á simnet.is en dns færsluna hjá ns1.hringdu.is og báðar aðferðir gefa ~9% packetloss.

Það er því ekki að sjá að það sé munur á aðferðum.

Ef ég væri kominn þetta langt í villugreiningarferlinu myndi ég einfaldlega redda mér öðrum router (til að útiloka main router).
Edit: einfaldlega til að átta mig á því hvar ég á að eyða tímanum í að villugreina nánar


Akkúrat, það er í vinnslu. Datt bara í hug að henda inn þessu með juno.isnic.is. Maður er bara að reyna að finna einhverja aðra "ónæma" og reyna að sjá hvað mynstrið er. Er líka búinn að opna ticket hjá Unifi.



Skjámynd

Revenant
vélbúnaðarpervert
Póstar: 921
Skráði sig: Fim 24. Jún 2004 12:36
Reputation: 74
Staða: Tengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf Revenant » Lau 26. Sep 2020 16:32

Ef þú ert að fá packet loss á fyrsta hop-i og línan virðist vera í lagi þá gæti routerinn verið sökudólgurinn.

Ef þú beintengir framhjá routerinum ertu að fá sama packet loss?


i7-2600K 3.4GHz @ 4.7GHz (103 MHz x 46) 1.416 V | ASUS P8P67 Pro | ASUS GeForce GTX1070 | Mushkin Blackline 8 GB CL9 1600MHz | Antec TruePower 750W | HAF X


dorg
has spoken...
Póstar: 165
Skráði sig: Lau 24. Jún 2006 10:19
Reputation: 1
Staðsetning: Reykjavík
Hafðu samband:
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf dorg » Lau 26. Sep 2020 17:43

Er að velta fyrir mér hvort þetta sé fyrsti pakkinn sem tími út af því að hinn endinn er ekki með mikinn forgang á að svara pingi og tekur tíma að koma þjónustunni í gang.



Skjámynd

Höfundur
izelord
Nörd
Póstar: 147
Skráði sig: Þri 24. Sep 2002 17:29
Reputation: 12
Staðsetning: Hafnarfjörður
Hafðu samband:
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf izelord » Lau 26. Sep 2020 22:43

dorg skrifaði:Er að velta fyrir mér hvort þetta sé fyrsti pakkinn sem tími út af því að hinn endinn er ekki með mikinn forgang á að svara pingi og tekur tíma að koma þjónustunni í gang.


Tvennt sem mælir gegn því. Packetlossið er að koma fram í mismunandi magni eftir tíma en ef þetta væri fyrsti pakkinn sem þyrfti að vekja þjónustu sem myndi deyja eftir ákveðinn tíma kæmi fram mun sterkara mynstur með stökum spikes.

Er með samanburðarping frá öðrum host á sömu destinations að hluta og ætti þá að fá sömu niðurstöðu, en geri ekki.



Skjámynd

ponzer
Kerfisstjóri
Póstar: 1265
Skráði sig: Þri 07. Sep 2004 18:18
Reputation: 12
Staðsetning: Router(config)#
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf ponzer » Lau 26. Sep 2020 22:52

Spurning hvort það sé eitthvað qos að eiga við þessa umferð. Er USG með einhverjar qos policy-ur?


Specs: Tölva, skjár, lyklaborð, mús og internet.

Skjámynd

CendenZ
Stjórnandi
Póstar: 2477
Skráði sig: Fös 04. Apr 2003 08:54
Reputation: 62
Staðsetning: Á þessu spjalli
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf CendenZ » Sun 27. Sep 2020 00:27

double nat að stríða þér ? búinn að taka allar snúrur úr sambandi og stinga aftur í og restarta routernum ?
Eða hvort þessar routes svari icmp requests og komi þ.a.l. sem loss, finnst voða skrítið að tæp 10% pökkum er að tapast

En ef þú sleppir USG-inu, hvað gerist þá ? er hann bridge eða með annað subnet ?



Skjámynd

L0ftur
Fiktari
Póstar: 61
Skráði sig: Mán 01. Ágú 2011 16:54
Reputation: 15
Staða: Ótengdur

Re: Ég fæ packetloss á allt nema Google!

Pósturaf L0ftur » Sun 27. Sep 2020 13:46

Ég myndi prófa annan router, eða factory reset og stilla uppá nýtt.


Z390 Gigabyte Aorus Elite RGB, Gigabyte 2080 Ti Gaming OC, i7 9700. 32Gb RAM
Z390 ITX Gigabyte Aorus Pro WiFi, Gigabyte Aorus 2080 Ti Extreme, i9 9900. 32Gb RAM
Z97 Gigabyte G1 Sniper, i7 4790. Asus ROG STRIX 2070. 16Gb RAM